Issue with Network Xrefs

I have this issue with some of our customers (OEM 2022, but also 2021 and 2019):
They got from other people drawings containing Xrefs located in some network paths.
When they try to open these dreawings it takes a lot of time to open (of course they haven’t the same network as the source, but this happens both the Xref is marked as “not found” or “unreferenced”).
It seems like the OEM wait for a network timeout to say: “Ok, go ahead”.

We made a test with one of this customer with this issue:
He tried to install the autocad 2022 trial on the same system and he tried to open the same drawing, the result is that the drawing opens immediately (with the Xref not found warning of course).
If I try to open with our OEM 2022 (the same as the customer) the same drawing on our pc, it opens immediately as autocad.

This is the question: anyone of us faced this issue? anyone has an idea of which parameter (maybe in the system) determine this behaviour?

We already tried the partial open or open the OEM by disconnecting the network, none worked.

Thank you for any help you can give us.

I will attach a sample drawing, but usually this works fine for many customer, so I’m not sure you will face the issue too. (148.4 KB)