Export to STEP issue after sewing with workaround

We ran into the following issue. We imported a CAD model, sewed the model, then exported it to a STEP file. We found the resultant STEP file was empty (no geometry). We worked with Techsoft support and they reproduced the problem, researched it, and provided the following workarounds. I thought others might find these helpful.


  1. Import the model, but do not sew
  2. Export to STEP
  3. Import the exported STEP, this time sew
  4. Export to STEP


  1. Import the model, and sew the model
  2. Export to PRC
  3. Import the PRC file (no need to sew again)
  4. Export to STEP

Note that the workaround we came up with initially was a little more involved in that, after importing the model and sewing, we created a new model file with a child PO, and then put the original model file’s children under that node. Then exporting to STEP worked.

I think the Techsoft support workaround is preferable as it provides a simpler way to address the issue. Many thanks to the fine folks in support for helping us with this!


Thanks for sharing Dave. It’s always so insightful to see you share how you solve issues you run across.

1 Like