I’ve setup HOOPS Communicator on AWS and I can access the viewer from within the machine, but I can’t access my application from outside the machine. What should I do?

First make sure you’ve run the settings_builder.bat and specified the correct internal and external IP address to your machine. If you’ve recently restarted the machine, the external IP of the machine may have changed. It depends on how you have the machine configured. Next, if you’re on a Windows machine, verify that you have opened up the following ports on in your Windows firewall: http://docs.techsoft3d.com/communicator/latest/build/server-setup.html
Lastly, you’ll need to open these same ports in the AWS machine configuration:
Windows: http://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/authorizing-access-to-an-instance.html

Linux: http://docs.aws.amazon.com/AWSEC2/latest/UserGuide/authorizing-access-to-an-instance.html

Also, on a Virtual Box VM, I’ve identified that I need to have my internal IP set to 0.0.0.0, so either use that value in the settings builder, or change all of your settings files to have the “bindToAddress” set to that.

Return to techsoft3d.com